技术文档
当前位置:技术文档

华为S12708与友商产品对接

来源:未知 时间:2020-12-03 12:21
 

      华为S12708设备替换核心友商Cxxxx后与汇聚友商交换机 eth-trunk对接协议down

  核心思科C6509配置如下:

  interface Port-channel9

  description TO-(xxxx-01)-Port1-1000M-01-Z

  ip address 192.168.1.1.162 255.255.255.252

  speed nonegotiate

  !

  interface GigabitEthernet2/15

  description TO-(xxxx-01)-Gi3/46

  no ip address

  speed nonegotiate

  channel-group 9 mode desirable

  !

  interface GigabitEthernet2/16

  description TO-(xxxx-01)-Gi3/47

  no ip address

  speed nonegotiate

  channel-group 9 mode desirable

  !

  友商交换机配置与友商C6xxx配置相同,端口及地址有变化,不在配置举例。

  替换后华为配置:

  interface Eth-Trunk9

  undo portswitch

  description TO-(xxxx-01)-Port1-1000M-01-Z

  ip address 192.168.1.1 255.255.255.252

  #

  interface GigabitEthernet4/0/12

  undo negotiation auto

  description TO-(xxxx-01)-Gi3/46

  eth-trunk 9

  #

  interface GigabitEthernet4/0/13

  undo negotiation auto

  description TO-(xxxx-01)-Gi3/47

  eth-trunk 9

  处理过程

  1、查看华为设备端口收发光,收发光正常

  2、查看eth-trunk 协议状态,端口UP,协议down

  3、查看对接OSPF邻居状态

  4、查看原有友商配置,对比配置

  5、切换华为eth-trunk lacp模式,变更为手工模式,协议down

  6、更改友商交换机设备端口下模式:channel-group 1 mode desirable 模式变更为channel-group 1 mode on

  7、查看eth-trunk状态,ospf正常

  根因

  华为S12700系列,LACP模式只有手工和静态两种模式,无法与友商动态模式对接,更改友商动态模式即可解决对接问题。

  解决方案

  进入汇聚友商交换机设备端口更改动态模式

  更改前

  interface GigabitEthernet4/15

  speed nonegotiate

  channel-group 9 mode desirable

  !

  更改后

  interface GigabitEthernet2/15

  speed nonegotiate

  channel-group 9 mode on

  !

  建议与总结

  华为S12700系列交换机与友商设备eth-trunk对接时,友商设备不用动态模式。


上一篇:华为IdeaHub触控屏设置界面及问题解答
下一篇:POE交换机未接地故障详述

售前客服

售前客服

电话:028-83252151

传真:028-85259033

咨询热线:15378180513
在线客服